Welcome to Open Carnage

A resource for Halo Custom Edition and MCC modding, with unique means of rewarding content creation and support. Have a wander to see why we're worth the time! - EST. 2012

CartmansPieHole

Halo won't load (EDIT: FIXED)

Posted (edited)

5/22/20 EDIT:  The problem has somehow fixed itself.  Not sure why it's fixed or how it happened in the first place.

I'm on Windows 10 and have been since the day it came out.  Halo worked fine until today.  Now what happens is, I load the game, I see the first screen, then the game minimizes.  The other normal stuff happens to existing open windows, for instance if I have a webbrowser open, it reduces itself to a smaller size.  When I click on the Halo Task along the Taskbar, I then see the Halo window restore itself, in a smaller window (I'm not purposely trying to run Halo in a window), and then I hear the normal Halo theme music playing.  I still don't see a screen, though.  Not even minimized.

I don't know how to insert a screen shot in these forums, I don't think it's allowed.

I tried both Halo PC and Halo CE exes and I get the same thing.

Any hints on how to fix this?

 

EDIT:  I just tested launching Halo in a window with another shortcut I made long ago.  That worked fine.  It just won't load full screen correctly, without the '-window' added to the target.  I never used to have to do this, which is weird.

Edited by CartmansPieHole

Share this post


Link to post
Share on other sites

Tiddy-bits:

That’s strange, have you had any updates recently? Sometimes windows updates affect drivers, try updating your drivers for your graphics card.

 Also, maybe something that has an overlay is causing issues. Maybe try closing things like discord.

Not sure if DXdiag would help, but you can try running that too. It will test directX for you. That’ll rule out that as an issue.

maybe halo is running in an unsupported resolution. Have you updated halo to the newest version? It effects graphics options


Specifications:

S3dpak - format - Imeta/ipak - format - Fmeta - format

Programs:

H2a-inflate - SuP

Share this post


Link to post
Share on other sites
8 hours ago, Zatarita said:

That’s strange, have you had any updates recently? Sometimes windows updates affect drivers, try updating your drivers for your graphics card.

 Also, maybe something that has an overlay is causing issues. Maybe try closing things like discord.

Not sure if DXdiag would help, but you can try running that too. It will test directX for you. That’ll rule out that as an issue.

maybe halo is running in an unsupported resolution. Have you updated halo to the newest version? It effects graphics options

I've been running the .10 exe since it was posted.  No further updates.

 

Ok, this is REALLY strange.  It literally was a fluke.  It happened yesterday, so I made this topic.  Before I went to bed, I downloaded a small update from Windows update, and that did nothing.  I went ahead and tested running the game just now and had no problems.  I honestly don't know what to think or why this happened to begin with.  Really bizarre, but it somehow fixed itself for now.  I was thinking about reinstalling but I have no idea where the disc is.  I'm glad I don't need to, now.

Share this post


Link to post
Share on other sites

It's because the HAC2 server was down. It will prevent game from launching when that happens.

WaeV and Zatarita like this

Oddly, this is familiar to you... as if from an old dream.          

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.