Welcome to Open Carnage

A resource for Halo 1 modding and tech, with unique means of rewarding individual content creation and support. Have a wander to see why we're worth the time! EST. 2012

Kavawuvi

Make Windows Defender not be annoying?

Windows Defender seems to have a habit of randomly eating up one CPU core for a couple seconds when opening a file, and this makes my PC sound like a jet engine. Any suggestions to fix this?

 

I don't currently want to install a different operating system. It's not that big of a deal for me, as it's not affecting anything I'm doing. It's just a minor nuisance at the moment.

Share this post


Link to post
Share on other sites

Members of Open Carnage never see off-site ads.

You can tell Defender to ignore a folder: PC Settings > Update and Security > Windows Defender > Exclusions > Add an exclusion.

 

I use this to whitelist folders I'm compiling into. All the object files make Defender go crazy.

Kavawuvi, Tucker933 and Solaris like this

Share this post


Link to post
Share on other sites

Normally I would recommend turning it off and getting Iobit Malware Fighter since it's the only protection software I've used with no noticeable performance impact. But I haven't used it since an update earlier in the year made it stop programs from opening their own files, rendering them unusable. It's been a long time since then so they might have fixed that problem.

 

If you decide to take a look at it, there is a premium version. But you can just find a valid key from some Youtube videos. Iobit makes really good software, but I'm not sure if I can say that when their key checking system is so bad that it lets you use the same premium key that thousands of other users are using as well...

Edited by ShikuTeshi

"You're nothing but a thing to me." -Tucker933 2016   

"Mine's not huge, but neither are my hands, so it's a real good fit." -Badga666 2017                

"It's not incest until it's in." -Caesar 2017

"Poison dart frogs aren't poisonous. Mankind is a poison and the dart frogs are the cure."-Somewhere on the internet  

Share this post


Link to post
Share on other sites

We've had this issue at work as well. On top of having to use McAfee of all things with the On-Access Scanner, this does passive-scanning of all new files introduced to the filesystem. I'd have to find it again, but there's a GPO and registry setting you can enable to stop it from passively scanning and only allow it to scan at the schedule times.


AWS/Linux Administrator | Angry Crab Admin

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.