Welcome to Open Carnage

A resource for Halo 1 modding and tech, with unique means of rewarding individual content creation and support. Have a wander to see why we're worth the time! EST. 2012

Down Under

Vehicle Teleports

28 posts in this topic

Tried & Failed: but below are the steps I took.

 

1) Under Sapien / Heiarchy / Game Data / Trigger Volumes

    - made a trigger volume (same size as vehicle)...named it "Enter"

 

also made a test vehicle named it "Vehicle1"

2) Under Sapien / Hiearchy / Game Data / Flags

    - made a "flag" called it "Exit"

3) Under Halo CE / Data / Scripts

    - typed the following script: 
(script continuous Vehicle_Tele
  (if (= (volume_test_object Enter Vehicle1) true)
   (object_teleport Vehicle1 Exit)
 )

 

[all in .hsc format]

 

4) Under Sapien: "compiled scripts" successfully & saved

5) recompiled map in tool

6) tested: did not work :(

 

any help or steps missing?

 

Thanks

 

   

 

Edited by Down Under

Share this post


Link to post
Share on other sites

Members of Open Carnage never see off-site ads.

The script seems fine, although it is missing a closing parenthesis which I assume was left out when you copied it.

 

First thing you can do is make sure the script was successfully added to the scenario by opening it in Guerilla and scrolling to "SCRIPTS". If you can find "Vehicle_Tele" then it was added. If the script was added, I guess you can try making the trigger volume larger.


dynamic.png

Share this post


Link to post
Share on other sites

No, I checked? Also checked debug.txt and nothing other than a player weapon deleting unexpectedly 

Edited by Down Under

Share this post


Link to post
Share on other sites

EDIT: First and foremost do this, replace your entire script with the following

 


<if this works you saved your file incorrectly>

 

If it still compiles correctly it's not compiling a script; verify it's a .hsc and not a .hsc.txt   file, and also make sure it's in your scenarios DATA directory, NOT TAGS.

 

Once you've verified that, here's your script.

(script continuous vehicle_tele
    (if
        (volume_test_object Enter Vehicle1)
        (begin
            (object_teleport Vehicle1 Exit)
            (sleep_until
                (= (volume_test_object Vehicle1 Enter) false)
            )
        )
    )

 

 

 

Debug.txt will only show errors from Sapien/Guerilla. Never ingame issues. Also script errors won't post they just wont compile if syntax is incorrect.

 

If that doesn't work post back let me know.

Edited by DeadHamster

Share this post


Link to post
Share on other sites

thanks for the revised script. However, same result. says it compiles correctly in Sapien but when I load Guerilla it is not in the script section. One note while in Guerilla it looks like the "exit /flag" I created for the same script appears under the script section in the "Cutscene" section? Is that where that flag goes when created? Curious why this imports over and the other part of script does not? I did check to make sure the file is in .hsc format and it is in the C:\Halo Custom Edition\data\levels\extinction pathway.

I am working with this map and have deleted the other V-teleports and wanted to add new locations. Found that there was one V-teleport not working on original map. I have renamed the scenario to "X-tinction" but it is located in same pathway as the original extinction.scenario. I did try and pull up both scenarios and the newly placed V-teleport does not pull across for either scenario.

 

Thanks

Share this post


Link to post
Share on other sites

If your scenario tag path is "tags\levels\extinction\X-tinction.scenario" then you have to save your .hsc files in "data\levels\extinction\scripts\".  Your "Exit" flag should be under CUTSCENE FLAGS, so there isn't a problem there. Also, there was nothing wrong with the original script, as I followed the same steps you listed in your first post and was able to get it working.


dynamic.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.