What happened to OC? - CLOSED Carnage?!

MXWK

Member
  • Content count

    33
  • Joined

  • Last visited

  • Raffle Tickets

    0

Reputation Activity

  1. Sunstriker7 liked a post in a topic by MXWK in Question about hosting game servers from home   
    Hey, thanks for your help. I'll answer each question to the best of my knowledge.
     
    1. Actually this started around 3 days ago, I had installed Windows Server Datacenter 2022 and I had some issues with it that I couldn't fix, I couldn't enable UPnP due to some missing dependencies, once I realized that I cannot troubleshoot anymore, I decided to reinstall the operating system, but this time Windows Server Standard 2022, the issue was there from the time I was using Datacenter and it still persists after installing the Standard version of Windows Server.
     
    2. I was testing earlier today with multiple Multiclients in the server when the console stopped updating and I lost connection, the console did not crash, it just stopped updating and the Multiclients started quitting one after another.
     
    3. It's random.
     
    4. I don't think so, usually when my server crashes, the console crashes too and it closes. In this situation, the console just stops updating. It does not crash. 
     
    5. The laptop is Lenovo ideapad 500-15ISK
     
    Processor    Intel(R) Core(TM) i7-6500U CPU @ 2.50GHz   2.60 GHz
    Installed RAM    8.00 GB (7.86 GB usable)
    System type    64-bit operating system, x64-based processor
     
    The laptop came with an  HDD.
     
    6. I think it's bare metal. Here are some of the results of the "systeminfo" command:
     
    System Manufacturer:       LENOVO
    System Model:              80NT
     
    7. Fresh installation.
     
    8. I am using Wired but I can also use Wifi. I have both adapters on the laptop. Here are some more results from the "systeminfo" command:
     
    Network Card(s):           2 NIC(s) Installed.
                               [01]: Realtek PCIe GBE Family Controller
                                     Connection Name: Ethernet
                                     DHCP Enabled:    No
                                     IP address(es)
                                     [01]: ///////////////////////////
                                     [02]: ///////////////////////////
                               [02]: Intel(R) Dual Band Wireless-AC 3165
                                     Connection Name: Wi-Fi
                                     Status:          Media disconnected
     
    9. The Modem is Etisalat, not sure how to access its model. The router is also Etisalat, got this information from the Router status page:
    Hardware Type
    Etisalat-S3
    Hardware Version
    v1
     
    10. I think I am using NAT, I just googled my IP address from my PC and my laptop, both are showing the same IP address of the DMZ I have setup a while ago. Even though I only configured the DMZ to be in my laptop. In my router settings page this option is there "Enable IGMP Proxy on wired LAN port." and its turned on.
     
    11. Firewall settings: There are many firewall settings that were configured automatically in my laptop when I installed the windows server OS. Should I mention those?
     
    I have allowed the following ports in my windows defender firewall for different reasons:
     
    Inbound:
    PORT 5985 TCP/UDP
    PORT 80 TCP
    PORT 2310/2312 TCP/UDP
    PORT 2302/2303 UDP
    PORT 21/22 TCP
     
    same for outbound.
     
    Portforward settings for my laptop are: 
    UDP
    2302
    2302-2303
    IPoE_DHCP
     
    TCP
    80
    80
    IPoE_DHCP
     
    UDP
    2310
    2310-2312
    IPoE_DHCP
     
    12. I have not installed any antivirus software, but windows defender's real-time protection is on in my laptop, I have not added the server files as exclusions, will add them now and will let you know if that fixes the issue.
     
    13. I went to Event Viewer ==> Windows logs ==> Application/System there are many events logged there, I searched for "halo" in both logs, and I found nothing.
     
    Here is a short video showing how the ping disappears when I click on the server multiple times: 
     
     
  2. Sunstriker7 liked a post in a topic by MXWK in Question about hosting game servers from home   
    Hey, thanks for your help. I'll answer each question to the best of my knowledge.
     
    1. Actually this started around 3 days ago, I had installed Windows Server Datacenter 2022 and I had some issues with it that I couldn't fix, I couldn't enable UPnP due to some missing dependencies, once I realized that I cannot troubleshoot anymore, I decided to reinstall the operating system, but this time Windows Server Standard 2022, the issue was there from the time I was using Datacenter and it still persists after installing the Standard version of Windows Server.
     
    2. I was testing earlier today with multiple Multiclients in the server when the console stopped updating and I lost connection, the console did not crash, it just stopped updating and the Multiclients started quitting one after another.
     
    3. It's random.
     
    4. I don't think so, usually when my server crashes, the console crashes too and it closes. In this situation, the console just stops updating. It does not crash. 
     
    5. The laptop is Lenovo ideapad 500-15ISK
     
    Processor    Intel(R) Core(TM) i7-6500U CPU @ 2.50GHz   2.60 GHz
    Installed RAM    8.00 GB (7.86 GB usable)
    System type    64-bit operating system, x64-based processor
     
    The laptop came with an  HDD.
     
    6. I think it's bare metal. Here are some of the results of the "systeminfo" command:
     
    System Manufacturer:       LENOVO
    System Model:              80NT
     
    7. Fresh installation.
     
    8. I am using Wired but I can also use Wifi. I have both adapters on the laptop. Here are some more results from the "systeminfo" command:
     
    Network Card(s):           2 NIC(s) Installed.
                               [01]: Realtek PCIe GBE Family Controller
                                     Connection Name: Ethernet
                                     DHCP Enabled:    No
                                     IP address(es)
                                     [01]: ///////////////////////////
                                     [02]: ///////////////////////////
                               [02]: Intel(R) Dual Band Wireless-AC 3165
                                     Connection Name: Wi-Fi
                                     Status:          Media disconnected
     
    9. The Modem is Etisalat, not sure how to access its model. The router is also Etisalat, got this information from the Router status page:
    Hardware Type
    Etisalat-S3
    Hardware Version
    v1
     
    10. I think I am using NAT, I just googled my IP address from my PC and my laptop, both are showing the same IP address of the DMZ I have setup a while ago. Even though I only configured the DMZ to be in my laptop. In my router settings page this option is there "Enable IGMP Proxy on wired LAN port." and its turned on.
     
    11. Firewall settings: There are many firewall settings that were configured automatically in my laptop when I installed the windows server OS. Should I mention those?
     
    I have allowed the following ports in my windows defender firewall for different reasons:
     
    Inbound:
    PORT 5985 TCP/UDP
    PORT 80 TCP
    PORT 2310/2312 TCP/UDP
    PORT 2302/2303 UDP
    PORT 21/22 TCP
     
    same for outbound.
     
    Portforward settings for my laptop are: 
    UDP
    2302
    2302-2303
    IPoE_DHCP
     
    TCP
    80
    80
    IPoE_DHCP
     
    UDP
    2310
    2310-2312
    IPoE_DHCP
     
    12. I have not installed any antivirus software, but windows defender's real-time protection is on in my laptop, I have not added the server files as exclusions, will add them now and will let you know if that fixes the issue.
     
    13. I went to Event Viewer ==> Windows logs ==> Application/System there are many events logged there, I searched for "halo" in both logs, and I found nothing.
     
    Here is a short video showing how the ping disappears when I click on the server multiple times: 
     
     
  3. MXWK liked a post in a topic by Solaris in Question about hosting game servers from home   
    What I would normally ask people in this situation:
    When did this start? When was the last time it happened? Does it happen in intervals or is it random? Does it happen when something on the server itself happens? (ie, server crash?) What are the laptop specs? Are you using an SSD or spinning disk?  Is Server 2022 running bare metal or a VM? If a VM, what hypervisor are you running it on, also Type 1 or Type 2?  Did this start occurring from a fresh installation or after an update? Wired or Wireless? What are your NIC devices? (ie, Intel Gigabit Ethernet, etc) What make/model of Modem/Router/combo/etc? Are you using NAT? Are you using a proxy?  What are Firewall settings and Port Forward settings?  AV/Endpoint Protection products running? If so, do you have exceptions in place to not scan the server directories and executables?  Last but not least, does Event Viewer > System/Application logs show anything for this? 
  4. MXWK liked a post in a topic by Sunstriker7 in Question about hosting game servers from home   
    The fact that people can connect at all and they can play fine for a while shows that your your network settings are likely configured correctly.
     
    Is this laptop using wifi? If so, stop it. Wire it up. Doing so will likely solve this issue. If you still have issues with an ethernet cord I would start by troubleshooting the physical connection between your laptop and your router/modem, then the physical connection between your ISP and your router/modem, then take a hard look at your modem/router itself. They do go bad and from my experience it usually starts with connection issues or crashes.
     
    There are several actual network experts here that will likely add their advice as well.
  5. Sunstriker7 liked a post in a topic by MXWK in Question about hosting game servers from home   
    Hey guys! How's everyone doing today?

    I recently installed Windows Server 2022 Standard operating system on my old laptop in hopes of turning it into a VPS to host more game servers (currently Halo PC game servers). It is connected to LAN and my internet speed at home is fast. I can access it through Remote Desktop & FTP. The problem is that the game server disconnects from time to time for some reason. It manifests as everyone on the server losing connection. This never used to happen in the VPSs I purchase. I also noticed that the ping does not show all the time in the server list. In the Halo PC server list, when I click on the server, the ping shows, but if I click it 3 to 4 times consecutively, one of the times, the ping will not show.

    In my laptop VPS, all the required ports are forwarded through the router, and DMZ is enabled on the laptop. I have also allowed the required ports through Windows Defender Firewall and I have also enabled UPnP while troubleshooting and it did not fix the issue.

    My question is: Is there a specific setting/software in windows that allows "persistent connections" that do not disconnect no matter what? I am hosting the same game server (the same files) from my VPS that I purchased online, and I never experienced this issue. The VPS I purchased online is a $6 VPS so I have more resources in my laptop VPS. I can host more game servers in the laptop VPS as I have more CPU cores and Memory.

    I did search online for an answer but did not find anything useful. What is the difference between actual VPSs that you purchase online and my laptop that has Windows Server Standard 2022?

    Maybe it's the Bandwidth/Internet speed? The VPS I purchased online has 2.00 TB Bandwidth and my home internet speed is: Download speed is 6.80 Mbps and Upload speed is 15.10 Mbps
     
    Is my home internet speed not good enough for hosting dedicated game servers? And if yes, Is there a way around that? I'd like to hear your opinions on this, thanks!
  6. Java liked a post in a topic by MXWK in SAPP PC/CE V 10.2.1 Remote Console Windows   
    Hey guys! How's everyone doing today?
     
    I recently started hosting from a remote windows server and I'm trying to find a way to connect to the console from my PC. I've found these 2 softwares that are present in this link 
    But it's either that I cannot install them right or they are not compatible with the latest SAPP which is 10.2.1
     
    Can someone share the installation instructions, if they are compatible with the latest SAPP, or show an alternative way to connect to the console remotely using windows 10?
     
    Thanks!
     
    Hey, I just searched up a little bit more about the issue. The problem was that I had to allow the TCP port of my Halo PC server in the windows firewall for the softwares to work. The connection to the remote consoles relies on the same port that you use to host your Halo PC/CE server, but TCP.
    Both softwares are working fine with SAPP 10.2.1
  7. Java liked a post in a topic by MXWK in SAPP PC/CE V 10.2.1 Remote Console Windows   
    Hey guys! How's everyone doing today?
     
    I recently started hosting from a remote windows server and I'm trying to find a way to connect to the console from my PC. I've found these 2 softwares that are present in this link 
    But it's either that I cannot install them right or they are not compatible with the latest SAPP which is 10.2.1
     
    Can someone share the installation instructions, if they are compatible with the latest SAPP, or show an alternative way to connect to the console remotely using windows 10?
     
    Thanks!
     
    Hey, I just searched up a little bit more about the issue. The problem was that I had to allow the TCP port of my Halo PC server in the windows firewall for the softwares to work. The connection to the remote consoles relies on the same port that you use to host your Halo PC/CE server, but TCP.
    Both softwares are working fine with SAPP 10.2.1
  8. MXWK liked a post in a topic by Chalwk in Ready to go Halo PC/CE Server templates   
    This project contains two semi-ready Halo server templates; One for Halo: PC (retail) and one for Halo: CE (custom edition).
    These servers are compatible with Windows and Linux.
     
    Default settings:
    Map Vote enabled (all maps, Classic CTF). Start-up commands can be edited in <server id>/cg/init.txt. SAPP commands can be edited in <server id>/cg/sapp/init.txt. No Lua scripts are configured (you'll have to add these yourself).  
    Running the server on Windows:
    Execute the run.bat file (located in the root folder). Running the server on a Linux OS with Wine:
    Navigate to ./Wine Launch Files/ and execute the run.desktop file. RELEASE PAGE
  9. MXWK liked a post in a topic by Zatarita in 2022 MCC Mapping Contest   
    Due Date: May 24, 2022
    Voting Opens: May 31st, 2022
     
    Welcome!
    So happy to have you here this fine Friday. @Takka has reached out to me with a fun opportunity. Like what they have done in the past, we're bringing you a mapping contest. The prizes sit at $100 for first, $50 for second, and 5 Raffle Tickets for third. Also first place ( Like our wonderful donors c: ) gets an exclusive badge next to their name they can use to brag to all their friends c;
     
    FAQ
    Q: What is it?
    A: All you need to do is create a custom map (not yet released), and submit a forum post about it before the deadline. This time our Halo overlords have blessed us with the editing kits for later games; so we felt it might be fun to expand our scope to allow any game from MCC. We've gotten some feed back from the community as well about previous mapping competitions and we hope this year we can fine tune things a bit better to the community. We will have a slightly extended submission duration at a month and a half from today. We wanted to keep the duration manageable, without incentivizing procrastination. This should also give some extra time to debug any issues we might have with the quirks of the newer editing kits. Submissions will be voted for 1 week, beginning a week after closing date. This will allow the community time to get acquainted with the new maps and form opinions. We are only going to allow one submission per person.
     
    Q: Can I work with a team?
    A: You are more than welcome to work in teams; however, this is not required. If you do work in a team though, you cannot submit individually. We request still that there is only one submission per person. This is to hopefully drive users to quality over quantity. In the case that you do work with a team, one user must be the designated liaison who will be responsible for receiving potential prize money and distributing it amongst the members. OC will not responsible for the distribution to individual members. This individual will also be in charge of hosting the map and creating the submission post.
     
    Q: How will I be contacted if I win something?
    A: In the event that you win a monetary prize, a moderator will reach out to you through the DM system on this website, and prize money will be paid out through PayPal. In the case you win tickets, the OC ticketing system will send you a notification on this website.
     
    Winnings
    1st Place: $100 via PayPal 2nd Place: $50 via PayPal 3rd Place: 5 Raffle Tickets  
    Additional Means of Reward
    Share the Knowledge: Tutorials based on an element of your submission will earn you 5 Raffle Tickets. Developer Commentary: Create a Work in Progress topic exceeding 100 words for your map, and you'll be awarded 1 Raffle Tickets per post per day, with a limit of 5 total tickets. Promotion: Share any link to Open Carnage, prove it, and earn 3 Raffle Tickets.  
    Rules
    Maps must be submitted to our MCC Map Releases section. Only one submission per person or team. Voting begins 1 week submissions close. Teams must have a designated liaison responsible for managing the release, and any winnings received.  
    Happy modding!
  10. MXWK liked a post in a topic by Chalwk in VPS Setup Instructions   
    This is a step-by-step tutorial that covers the installation of a Ubuntu VPS with Wine and a VNC server for remote connection.
    The hosting company that I use in this tutorial is Vultr but will work for other providers as well.
     
    Please see this page for the guide.
     
  11. MXWK liked a post in a topic by Patata in Mod Christmass CE / PC   
    [ESP]
    Hola a todos, modifique los mapas oficiales agregándole un simple gorrito de Santa a los spartans, funcionan bien en el multijugador con Chimera reciente, desconozco si puede servir en Hac2 o versiones viejas de Chimera ya que los mapas fueron descomprimidos y compilados con Invader, los mapas base del Custom Edition son parte de los mapas Refinados con la HUD corregida y algunas otras texturas / shaders corregidos.
     
    Antes de la instalación de los mapas has una copia a tus mapas por si te pasa algún error al abrir los mapas.
     
    [ENG]
    Hello everyone, I modified the official maps by adding a simple Santa hat to the spartans, they work well in multiplayer with recent Chimera, I don't know if it can work in hac2 or old versions of Chimera since the maps were unzipped and compiled with Invader, Custom Edition base of maps are part of the Refined maps with corrected HUD and some other textures / shaders corrected.
     
    Before installing the maps, make a copy of your maps in case you get an error when opening the maps.
     
    Merry Christmas!
     
    Links:
    Maps Custom Edition.rar
    Maps Combat Evolved.rar
     

     

  12. Takka liked a post in a topic by MXWK in I Made A Freelancers Marketplace Website!   
    Thanks!
     
    I'll look into those points, dunno if I'll be able to fix them though, I don't know how to edit the theme myself...but maybe I'll find a workaround for them, and hey you can build a much better site if you know WordPress theme editing, all I did was purchase the theme and install it on my VPS, after installing Webmin/Virtualmin, and then WordPress.

    There are also many other premium scripts on CodeCanyon and themes on Themeforest, those of which are about CyptoCurrency and Ad Listing websites, restaurant management scripts that come with their mobile apps integrated with the website. Many business ideas to choose from. But the problem lies in marketing, no point in purchasing any of them if no customer will buy the product they offer.

    Just sharing what I've been researching lol, I was planning on hiring someone to do email marketing for me, to send emails to a targeted audience. Have you ever tried doing that? And do you know of any other effective marketing strategies (other than paid ads)?
  13. MXWK liked a post in a topic by Takka in I Made A Freelancers Marketplace Website!   
    That's quite a clean site, and a good idea.
     
    Friendly design notes: It looks like the responsive styling has some issues between 1620px & 1200px width. The image on the right gets displaced and doesn't looks clean closers to 1200px, and the text on the logo overlaps with "Get Started" at the higher end of that width range. The footer gets clunky under 1200px, also.
     
    Way better site than I could build. =]
  14. Takka liked a post in a topic by MXWK in I Made A Freelancers Marketplace Website!   
    Hey guys!
     
    Been a while since I posted on OpenCarnage, how's everyone doing? I'm doing great!
     
    So I've been trying to start my own SAAS (Software As A Service) business since it's one of the most passive income streams, and I got the idea of developing my own freelancer marketplace website, mainly because I want to freelance and I like making new websites. So I went ahead and made it. Check it out!
     
    The website is made using WordPress with the Premium Exertio theme that I had to purchase from ThemeForest. It's fully functioning with PayPal as the only payment gateway currently. 
     
    If you are interested in using the website I made a coupon that is valid until 7/1/2022 on our top packages, don't miss out! 
     
    I've read some posts on this forum of Web Developers sharing their experiences, this is my first commercial project so do let me know if there can be any improvement in the website! I accept both positive and negative comments so don't worry lol but calm down with the negative ones xD
     
    Also, any advice on how to market the website would be really useful. 
     
    Thanks and have a good day!
  15. MXWK liked a post in a topic by Denn in How to install wine version 1.7 on Ubuntu 20.04?   
    1. Wine  6.0.1
    2. Ubuntu 18.04 with LXDE desktop
    3. Wine 6.0.1 seems to work perfecly with sapp 10.2.1
     
    I run on Digital Ocean VPS
  16. MXWK liked a post in a topic by Enclusion in Renaming Players if Bad Words Detected In Name   
    Made at the request of @CartmansPieHole
     
    This script will changed anyone who joins your server's name to something else if their name contains something in a list of banned words/characters. Server moderators can use this to ban bad words in names or just names you don't like. This will log a message to the console when a players name is changed.
     
    Download: https://raw.githubusercontent.com/TagiaNetwork/SAPP-Scripts/master/BannedNameChanger.lua
     
    Video: 
     
    Credits:
    OnNameRequest by @Devieth
    badwordsarebad by @Kavawuvi
     
     
     
    BannedNameChanger.lua
  17. MXWK liked a post in a topic by AntiMomentum in How to install wine version 1.7 on Ubuntu 20.04?   
    Strange, I use the same install script for Debian 9, Ubuntu 20.04 LTS, Ubuntu 21.04 and Ubuntu 18.04 LTS to install Wine and it runs sapp 10.2.1 with or without UPX. 
    This script installs Wine 5.0 on Ubuntu 20.04, Wine 3.0 in Ubuntu 18,  and Wine 1.8.7 on Debian 9 Stretch. But it does correctly run my halo server.
    https://github.com/antimomentum/haloce/blob/master/Debianwineinstall.sh

    You may want to remove/comment out the first line if you run this on Ubuntu. Tbh I've forgotten to do that and it still worked in Ubuntu anyways xD
     
    In Ubuntu 18.04 LTS I did have to do apt install wine32 manually after running the script.

    This installs 32bit Wine on 64bit Alpine. This is the only version of 64bit Alpine I've found that would run my halo server correctly:
    https://github.com/antimomentum/haloce/blob/master/Alpine64bit-3.12-Wine32bitinstaller.sh

    However i386 versions of Alpine do tend to work too, like the one pulled in the Dockerfile.


    No UPX sapp files, at the bottom of the page
    http://halopc.com/sv_extensions/

    smol bitmaps.map file if you want it (I use this personally, not required)


    I also just went ahead and uploaded my server files as an example.
    halopull.zip
    *Edit*
    When Halo server starts it will ask the OS to do dns lookups in both Windows and Linux by default for the master server ip. These two commands will allow the Halo server to skip the dns lookup in Linux, only needs to be run once on a fresh OS:
    echo "34.197.71.170 hosthpc.com" >> /etc/hosts
    echo "34.197.71.170 s1.master.hosthpc.com" >> /etc/hosts

    As a side note Windows has a hosts file as well.

    **Edit 2**
    UFW might also be automatically installed on your Linux VPS. UFW (uncomplicated firewall) is a frontend for iptables. This could end up blocking Halo from reaching the master server by default and preventing Halo from booting properly/showing in the list.
    Try:
    ufw stop
    to stop it until reboot or manually started
    ufw disable
    to persistently disable it.

    As a side note the firewall.sh script on my Github requires ufw to be stopped/disabled and to have the master server in hosts (the two echo commands above). More details about my fw are at the top of the firewall sript.
  18. MXWK liked a post in a topic by mouseboyx in How to install wine version 1.7 on Ubuntu 20.04?   
    10.2.1 is the latest version of sapp.dll
    1.10 is the latest version of haloceded.exe  http://hce.halomaps.org/index.cfm?fid=6797
     
    I'm unsure which version of haloceded.exe is included in the download from http://xhalo.byethost18.com/, but I don't think you want that version, it's definitely not 1.10.  That's also a very old version of sapp.dll from the looks of the web page.
     
    Edit:
    You can also get haloceded.exe from here, but the version of sapp.dll included with it doesn't work on linux https://www.elitegameservers.net/sapp/download you would replace or use the sapp.dll and strings.dll with the ones from https://opencarnage.net/applications/core/interface/file/attachment.php?id=1154 to get it to work on linux.
     
  19. MXWK liked a post in a topic by mouseboyx in How to install wine version 1.7 on Ubuntu 20.04?   
    This doesn't answer your question, but this post ended up fixing my issues:
    I wasn't able to get sapp to run on ubuntu 20.04 unless I used the version of sapp linked in the above post.  However, I'm using a 1.10 version of haloded.exe I'm not sure whether it would work with previous versions.  What patch version of haloceded.exe are you using?  I was able to run wine 5.0 with haloded 1.10 and sapp 10.2.1 on ubuntu 20.04 by using the SAPP.7z download in the above post.
     
    Make sure you run haloded in a 32bit wine prefix also:
    https://askubuntu.com/questions/177192/how-do-i-create-a-32-bit-wine-prefix
  20. MXWK liked a post in a topic by Kavawuvi in How to install wine version 1.7 on Ubuntu 20.04?   
    I generally use the latest version of Wine on my Arch Linux install, version 6.16, though SAPP is known to have issues with Wine, of course.
     
    If you want to install an old version of Wine on a new distro, you may need to compile it from source as most distros do not provide such old, 8+ year old versions on their repos. On Ubuntu, this can be achieved by pulling the Wine repo, checking out the wine-1.7.53 tag, and then compiling.
    git pull git://source.winehq.org/git/wine.git git checkout wine-1.17.53 ./configure make You will, of course, need to make sure you have build tools installed to compile (apt install build-essential should do it), and this may take a good while.
  21. MXWK liked a post in a topic by mouseboyx in CD Key Check Is ON In My CE SAPP Server   
    I honestly have never tested changing that memory address, I was thinking that with sapp 10.2.1 the cd key check is disabled out of the box.
     
    I tried some code, this ended up crashing haloded with an exception error, but I'm using sapp 10.2.1.  With 10.2.1 I never had a problem with cd key checks, I also don't know if those memory addresses or correct, or when to write to them.  It could be a completely different address that is created by sapp that needs to be changed.  Those addresses in offsets.lua probably pre-date halo patch 1.10 and are geared towards phasor.
    api_version = "1.12.0.0" function OnScriptLoad() register_callback(cb["EVENT_GAME_START"], "OnGameStart") end function OnGameStart() --PC --hashcheck_patch = 0x59c280 --CE hashcheck_patch = 0x530130 write_byte(hashcheck_patch, 0xEB) -- Disables Halo's hash check (0x74 to reenable) end  
     
  22. MXWK liked a post in a topic by mouseboyx in CD Key Check Is ON In My CE SAPP Server   
    The unrestricted version of Gandanur: http://www.gandanur.com/
    It has a command for disabling the cd-key check, however installation of Gandanur requires replacement of haloded.exe and strings.dll.  It might be possible to use gandanur along with cheat engine and keep running the command:
    sv_cdkeycheck 1 sv_cdkeycheck 0 sv_cdkeycheck 1 sv_cdkeycheck 0 etc... Then use cheat engine to search for a bit value in haloded.exe of something being toggled between 0 and 1 based on what you changed it to using gandanur, however the fact that gandanur requires haloded.exe to be replaced with their own version makes me think that the memory address may or may not be correct if you tried to write to the same address in the copy of haloded.exe that sapp uses.
     
    If this doesn't work then gandanur is a solution for disabling the cd key check if you don't want to use phasor or sapp.
     
    Edit:
    I didn't test to see whether this works, but there is a memory address specified here:
    https://github.com/Chalwk77/HALO-SCRIPT-PROJECTS/blob/ca1bcdf2636debc4e3622fff48614626bb7b3043/Miscellaneous/offsets.lua
    --PC --hashcheck_patch = 0x59c280 --CE hashcheck_patch = 0x530130 write_byte(hashcheck_patch, 0xEB) -- Disables Halo's hash check (0x74 to reenable)  
  23. MXWK liked a post in a topic by AntiMomentum in Help in setting up VPS for Halo CE Dedicated Server   
    Yeah so mostly/completely just sounds like a path issue. So here's a tip for both Windows and Linux you might already know when starting haloceded.exe, you can add a -path switch to it to force Halo to use one directory, rather than the Documents\My Games\Halo CE it defaults to without a -path switch for sapp files and the mapvotes, commands,etc. So:

    You have 1 folder named halopull
    In halopull:

    A folder named maps
    A folder named sapp   <--alias.txt, commands.txt, events.txt, init.txt (sapp's init), mapcycles.txt ,mapvotes.txt are in this sapp folder.
    --in the sapp folder there's also the lua folder. You put lua scripts in the lua folder
    A folder named savegames  <---gametypes
    A folder named saved
    Then files:
    haloceded.exe
    banned.txt
    init.txt
    motd.txt
    sapp.dll
    Strings.dll 

    All in halopull. You may have more files, that's just a barebones example. As long as "halopull" is in the same directory as "Dockerfile" it will build correctly, as long as your halo paths aren't still mistaken somehow or there isn't something wrong with the files themselves. Also assuming you are using 10.2.1 sapp. 

    In Wine without Docker:
    you cd into halopull and start halo like this:
    wineconsole haloceded.exe -path .

    The Dockerfile essentially starts halo in the container this way too. The dot is relative (for Linux, in Windows i think it's \ for relative path I could be wrong about WIndows though).
    **Edit 2, Lua**
    In sapp's init.txt you must have:
    lua 1
    lua_load thescript
    lua_load race

    Assuming the lua scripts' file names are thescript.lua and race.lua

    But I also recommend this in sapp's init too:
    auto_update 0
    network_thread 0

    There's also some way to use lua scripts specific to a map in the mapcycle. I'm not sure how exactly that works though maybe there's a post or something about it. Anyways if your issues were just path and lua that all should at least get it to running without crashes. In past experiments I've sometimes had to use this in the sapp init too:
    max_idle 0

    But that's a last resort sort of thing. And I'm not sure how that works either.

    *Edit*
    If you want to run multiple halos with just Wine (no Docker) from the same server without having to use an ssh screen for each Halo, you can install "screen". This will allow you to start haloceded.exe detached and you can attach to the halo console later or even make scripts to give halo commands without having to attach to any halo console. Once you have your Halo server working you can do this:

    apt install screen   <--assuming Debian/Ubuntu

    Here's an example script that would start 2 halo servers from the same files, but on different ports 2302 and 2304:
    screen -S "halo" -d -m
    screen -r "halo" -X stuff "cd halopull^M"
    screen -r "halo" -X stuff "wineconsole haloceded.exe -path .^M"
    screen -S "2halo" -d -m
    screen -r "2halo" -X stuff "cd halopull^M"
    screen -r "2halo" -X stuff "wineconsole haloceded.exe -path . -port 2304^M"

    You can then attach to them:
    screen -xr halo
    or
    screen -xr 2halo

    Hold Ctrl A and D to detach. You can even remotely detach another screen if you can't Ctrl A and D, provided you run this from a terminal or screen not already attached to a halo console: screen -d 2halo

    Or make a script to automatically turn on afk kick after an hour without attaching at all:
    sleep 3600
    screen -r "halo" -X stuff "afk_kick 300^M"

    The ^M basically means "press enter" to screen. "stuff" is actually part of the screen command.
  24. AntiMomentum liked a post in a topic by MXWK in Help in setting up VPS for Halo CE Dedicated Server   
    @AntiMomentum Hello, thanks for your response. I managed to get a SAPP server up and running by copying the entire Halo CE directory into the server files directory. Dunno what exactly happened there, but it was fixed, with only one issue, the server keeps crashing. 
     
    I am currently trying out docker to see if it will fix the crashing, but I can't seem to be able to load the Lua scripts. Where exactly am I supposed to put SAPP's init and the Lua files I want to load for my server? As well as the mapvotes, commands, etc.
     
    Thanks!
  25. MXWK liked a post in a topic by AntiMomentum in Help in setting up VPS for Halo CE Dedicated Server   
    https://github.com/antimomentum/haloce

    Scroll down to the step by step section.

    Also keep in mind that depending on the cloud provider you use, there could be security rules you need to set up outside the host OS to allow internet traffic to it. This is true for AWS, Google cloud services, and Azure if I'm not mistaken.

    Providers like Linode and DIgitalOcean don't have that extra step outside the OS.

    The github page should have all the info you need to run a halo custom edition dedi server with sapp and lua on Linode in Ubuntu 18.04 LTS server

    Here's the shortcut:
    apt update
    apt upgrade -y
    apt-get install docker.io
    docker run -e INTERNAL_PORT=2302 -it -p 2302:2302/udp -p 2303:2302/udp antimomentum/haloce
    Wait a few minutes, grab some coffee. 
    Done. You are booted to the haloceded.exe console and the server is running with sapp, and will show up in the game's server list

    There's another section on that github page for installing your own server/sapp/ idk what else files to a docker build.

    My server using this container was full last night. CPU usage was at 10-21% and ram was under 300mb on bloodgulch. This might even run in free tier cloud services lol, maybe depending on what maps you use.