Welcome to Open Carnage

A resource for Halo 1 modding and tech, with unique means of rewarding individual content creation and support. Have a wander to see why we're worth the time! EST. 2012

Thomas

Member
  • Content count

    69
  • Joined

  • Last visited

  • Raffle Tickets

    0

Everything posted by Thomas

  1. So I have recently heard that someone calling himself "Roberto" has released a new aimbot that can evade SAPP detection scripts... Is there something that scipters in SAPP can do to combat this, evil scourge on the Halo community? Here is the video he uploaded and the download links... The second one, a so called "injector.dll" file cannot be downloaded as Mediafire did the right thing and marked it as "dangerous", well done to them... The download links are on the youtube page if this helps.
  2. It is the cheats that are destroying this "small community". We know that there are clans out there that allow cheats to play with impunity, but we are certainly not one of those clans. We are doing everything that is possible to keep those cheaters out of our servers, regardless of who they are! A lot of people who play Halo actually come to our boards, and tell us that someone is cheating, and while the most recent ones, we know about as we have banned them before, some multiple times, they keep coming back by changing thier IP, but we have found a potential solution and have implemented it. So far, it appears to be working well as a matter of fact. What I find happens a lot, is that players on Halo, especially a certain few, tend to cheat, and wait to be banned, be it via the autoban system, or via an admin that bans them. They then run to youtube or Facebook and post a video of them being banned but only show the parts where they were not cheating, and make it out that they were banned for "no reason". That is annoying as they never show the full truth and only half of what actually happened. I have no started to live stream all of my games, and now that I have a faster upload speed, I can do so in much better quality. It helps when I need proof of cheats in our servers. Recently, we find that a lot of players are glitching, especially in DangerCanyon where the 2 bases meet with a cliff in between, I have filmed it happen and banned the player doing it, its cheating, and will not be tolerated.
  3. @Kavawuvi, I am as active as I can be, but I find that a lot of players are online when I am in bed, since the US for example are between 5 hours (east coast) and 8 hours (west coast) behind us. This of course does not include Hawaii. It is a struggle to be around when I am so tired, and sometimes, especially at the weekends, I sleep all day to be up and able to play online most of the night, then back to bed for the day. It is something I am trying to mmanage, but it is not easy, believe me. This is why I thought a script could be written that would help us to combat these botting scum of the Halo Community. We have had members of other clans post about people botting in our servers, and most occasions they provide evidence, and I spend hours updating all of the servers to keep that player out, the updates are always done at the weekend usually on a Sunday. People also report that known cheats like "fou" are playing in our servers and I have managed to get the BoS "event" thing to work as well. What we need are more members that we can promote to admins and have them help to moderate our servers, but these days, it is very difficult to get people to join us!
  4. Why not? Also, I have sucessfully changed the settings in the server files to show "[PLAYER_NAME], your IP has been logged." Thus, player IP's will no longer be displayed, but are still entered in to the server logs.
  5. So we have been having a lot of issues with a paticular player recently, calling himself "fou". We have had many occasions where he has seen fit to enter our servers and wall all the time, and I do mean ALL the time. We have had many people visit our forums, often from other clans, and tell us about him and we have been trying to find ways to keep him out of our servers, and the only viable solution was to ban his CD key until we find a solution to this issue. Banning his CD key has resulted in many people visiting our forums saying that they have been banned for no reason, and in a way they are right, but it turns out that banning "fou's" CD key, has also banned them without me realising until today when 2 members of our clan contacted me saying that they were banned. I looked at the logs, and pinned it down to the CD key that they were using being identical to "fou's". I have an event added to the "events.txt" file that should be banning people when they enter, but it does not appear to be working, and wondered if there is some help here that I can get to make it work, so I can keep "fou" out, hopefully. Also, I have changed the server so that instead of saying the players IP address when someone joins, although it is omnly to them, I changed it to say "Your IP has been logged." but after rebooting, it still shows the IP of the player and I qam not sure why. This could be related to the cache, assuming SAPP has one, if so, where would I find it? Thanks again. @Java @Tucker933
  6. I assume you mean "fou", if so, I would have to agree with you. He is one of many toxic players that just don't know how to take know how to take no for an answer! We have had some players from other clans report him, and I have him on our BoS list, and he is unlikely to be removed because he is a cheater and for no other reason. He walls, and there have been reports that he is also an aimbotter as well, which would not surprise me. He will never be allowed on our servers again, as he is not only on a BoS order, but once I get that "nameban" installed, I will be adding him to it, assuming it operates in a similar way to the original "banned.txt" file.
  7. I have found that the IP's that this idiot uses are all from the same general range, I mean the first block is ALWAYS the same, but the others seem to be different. Also the CD key he uses is the same so far in all the entries that I have seen of him joining. We have banned him so many times, that I have lost count, but he always ruins the game for everyone with his cheating and it is frustrating that we cant keep him out. If I was to ban the first block of his IP, assuming that is possible, it would potentially ban millions of other potentially innocent players. This is why I am trying to find a way to keep just "fou" out, and not many other players as a result of that idiots cheating. After updating the events file, the IP is still shown to the player, when I changed it not to, what could be causing it? Side note, I did try to reload SAPP, but got the same issue.
  8. Is it possible to get the SAPP files to save in the same location as the init.txt file which I can also move to Google Drive?
  9. This will be my first post in this particular board. We have had issues with our servers... On or about August 8th, we had a massive power surge that destroyed our rack and the servers contained within, and the hardware attached to them all. more details here. What I have come up with as a solution is using Google Drive Sync to constantly sync our server logs to Google Drive as a safety net, as a backup. This means that we dont have to worry if the server crashes again as the entire "cg" folder that contains the logs and various gametypes can be saved there. My question is that SAPP, which we use on all of our servers may be a bit of a tricky one to back up there. I wanted to be able to do the same thing as in the command line on the shortcut to start the servers using the "-path" command which forces the server to load the SAPP scripts and gametypes from the Google Drive folder containing them. We can also set the "-exec" command to set it to load the init.txt file of the server from the same location in the same way. SAPP appears to store its mapcycle, ipbans list, admins list and all that in the server root in various text files but I cannot seem to set it to load them from a different location. Is there anyone in this board that knows of a solution to do this? I wanted to be able to save all logs, gametypes, and SAPP files (ipbans, mapcycle etc) to Google Drive and sync them all there constantly to try and reduce the risk of losing everything again in the same manner as before. This would mean that we would just have to restore the servers and maps to the same location and then we can literally start them instantly and should be just as before. Syncing the SAPP folders directly from the game folder is impossible as it would mean doing it with the entire folder, each one several hundred MB, some are a few GB, and we dont have enough GD storage for this. Logs are literally no issue for this since each one is only about 2MB. Our Google Drive account has plenty of space for this. Can anyone think of a way that this can be done? Thanks in advance.
  10. Its only stored in the Google Drive folder which is located in the user files, more specifically, my account, and synced constantly to Google via Google Drive Sync so we reduce the risk of losing stuff in the future. Similar to Dropbox.
  11. Thanks. I will look in to this and report back with my results. *EDIT* After looking at the article linked by Kavawuvi, the game servers are stored on multiple seperate physical disks with different drive letters. The article appears to indicate that the symbolic link option is restricted to a single volume, meaning that it would not be possible to use this as an option. Thanks for the idea.
  12. I thought the Matrix was unhackable? LOL!
  13. It turned out to be a peer issue. A really big one at that. I am not certain where or where the issue actually lies, but suffice to say that for the most part the issue has gone. I do still get the odd lag spike, but it was nowhere near what it was when Solaris was assisting me. I would like to thank everyone who suggested possible fixes in this thread, especially to Solaris who took the time out of his own day to help me figure out what the problem actually was, and after passing this data to my hosts, was able to get them to try a few new things they never did before. I saw a pretty dramatic improvement when they moved me to a new switch, and that seems to have cured the issue for the most part.
  14. So the story goes like this: I have hosted a server with a company in Pennsylvania now for around 2 years and earlier this month, on or about August 8th, they had equipment failure causing a massive power surge to go to the rack where our server is located. It fried the entire rack of servers and all the hardware in them, including drives, motherboard and power supply. I am not entirely sure if it fried the RAM as I was not told this, but I suspect that it is at least damaged. The RAM we had in our old server is possibly in our new server, could this be a cause of the lag we are experiencing? Our server specs are as follows... NOTE: This setup was working just fine before the above described event, although has some minor changes, like the WD Black before was a 2TB, now it is a 1TB. Apart from the other drives, that is the only change and the system SSD is now 240GB instead of 120GB. A pair of Intel Xeon X5650 with each one having 6 cores and 12 threads, making it 12 cores and 24 threads 72GB of RAM (all of them are 4GB modules) DDR3 (possibly 13333Mhz) We also have a 56GB page file to bring it up to 128GB of virtual RAM, a 240GB SSD (to run Windows and programs) a 1TB WD Black (7200RPM drive with 32MB cache) a further three 1TB drives for backups and data storage for installing more servers, saving maps and other server installs for access, to not cause lag on the game servers drive (dedicated 1TB WD Black as above) 1Gbps line Server 2008 R2 (64-bit) Is there anyone out there that knows what could be causing this? I have tried everything I know, and I am only pulling my hair out trying to fix this! The lag seems to be intermittent, but I am not sure whats causing it, I could upload a video to show you what is happening if you need me to, which I will start converting once I have posted this thread, if any replies, I will post it to a reply instead.
  15. This is odd, they did pings and lost nothing... this is really frustrating...
  16. Here is a video I took in one of our servers, and I was the only player at the time in all servers, perhaps this helps determine the cause... The video shows how it is lagging by "teleporting" and "jumping" in some places quite significantly to different parts of the map and warping through walls. I still have no idea what is causing it other than a possible DDoS attack. Does anyone have any ideas or suggestions? This is making me pull my hair out!
  17. I am not aware of how to run constant pins tho... Also, we have a member from the USA who lives around 300 miles from the server, gets around 33 - 66 ping and even he lags like we all do. Does this help?
  18. Java, thank you for your reply... My dedicated server hosts actually completely rebuilt my box with the same specs, so it cant be the box, unless they accidentally added faulty hardware. But it is not just me that is being affected, it seems that someone in our gaming organisation seem to be lagging as well, and they are in the same state as the server, and have 33 ping... I don't understand whats going on...
  19. The server is completely dedicated... Not a VM...
  20. Well, we have a server, running Windows. We have noticed that for some time, our dedicated servers CPU has been using up in the area of 95% to 100% usage on both "System Idle Process" and "WMI" or "Windows Management Instrumentation". Oddly, when I disable or stop/pause) WMI, the CPU use drops to around 10% - this is with some 200 game servers running on it at the same time I might add and appears to be more normal - considering we have 8 cores and 16 threads! We also had a lag issue that seems to have been caused by two Trojans and a pair of PUAs ("Potentially Unwanted Apps") that we found and removed using AVG Business on a free trial (I plan to register it moving forward for our protection). The screenshot below shows that the "System Idle Process is eating CPU cycles! I have been in communication with our hosts for a few days now trying to resolve this matter and so far, we have managed to eliminate 2 of our three issues. We still have the high CPU issue which appears to be caused by WMI and "System Idle Process". I also found that Internet Explorer had some sort of proxy configured, which I have now removed and asked it to "auto detect" settings and now that is working as well. I have done a lot of research that in total over the last two days, I have spent a total 21 hours trying to work out what is going on, and although I did find two issues which I have managed to resolve, I am still at a loss as to what could be causing the WMI high CPU use on our dedicated server. I have tried everything I can think of! Our server specs listed below for reference... Intel Xeon E5530 x 2 (yes, I do mean a pair of pysical CPU's) with 4 cores and 8 threads on each 72GB DDR3 1333MHz (18 x 4GB) 120GB SSD (running Windows only) Three 2TB drives one is a WD Black with 64MB cache and 7200rpm that is "hosting" all of our game servers only although I may have to get a second smaller drive when we start hosting ArmA servers for =DN=. A second WD Black and a Toshiba. 1Gbps port What else you need to know? I have tried everything I can think of to resolve this and have got nowhere but more frustrated and annoyed with it refusing to stop eating up CPU cycles. It causes some major lag in our game servers and even causes people to be kicked because of this one issue. I don't know what I am missing, can anyone help me out here? I am a wits end! Let me know if you need further information... Thanks again...
  21. Booting in to safe mode is an absolute no no! The server is thousands of miles away in another country and it would be silly to travel there when I cant get access anyway. I have emailed our hosts with a full breakdown of what is happening to see what they can do since they are actually there in the data centre where our server is located. Lets see what they say... Thanks for your suggestion Sunstriker7, I cannot get to the server to do what you are suggesting... Sorry.
  22. OK then people... Assuming I can bring this thread back to life again... Here is my home internet... And here is the connection to our dedicated server: I will be honest here, I would kill for internet like that at home!!!!!!!
  23. I've been trying to figure out why our Call of Duty: World at War servers keep shutting down when they are left online. Anyone have any ideas on why that could be? I know the configuration is correct as they run just fine when they are working but not after a while, a few days of being online...